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About This Guide

This Novell ZENworks Configuration Personality Migration Reference consists of conceptual information
to help you install and use Novell ZENworks Personality Migration.

The sections include:

¢ Chapter 1, “What Is Novell ZENworks Personality Migration?,” on page 7
¢ Chapter 2, “Installing ZENworks Personality Migration,” on page 11

¢ Chapter 4, “Manually Migrating Personality Settings,” on page 17

¢ Chapter 5, “Automatically Migrating Personality Settings,” on page 27

¢ Appendix A, “Best Practices,” on page 41

¢ Appendix B, “Troubleshooting Personality Migration,” on page 43

¢ Appendix C, “Migration Settings,” on page 47

¢ Appendix D, “Supported Settings in Personality Migration,” on page 53

¢ Appendix F, “Cross-User Migration Scenarios,” on page 67

¢ Appendix G, “Documentation Updates,” on page 73

Audience

This guide is intended for network administrators and IT professionals who manage network
resources, and who want to use ZENworks Personality Migration to preserve the applications and
configurations on network workstations when users begin using new hardware.

Feedback

We want to hear your comments and suggestions about this manual and the other documentation
included with this product. Please use the User Comments feature at the bottom of each page of the
online documentation.

Additional Documentation

ZENworks 115SP2 is supported by other documentation (in both PDF and HTML formats) that you
can use to learn about and implement the product. For additional documentation, see the ZENworks
11 SP2 documentation Web site (http://www.novell.com/documentation/zenworks11/).

About This Guide 5
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What Is Novell ZENworks Personality
Migration?

Novell ZENworks Personality Migration is part of the Novell ZENworks Configuration Management
product line.

A personality is a collection of applications and system settings that a user commonly uses on a
device. Typical settings can be desktop wallpaper, e-mail account settings, browser proxy settings,
files and folders, archived e-mails, Microsoft office templates, Microsoft Office macros, etc.

ZENworks Personality Migration provides a way to automate this process, both on a standalone
device or from a centrally managed console. The process significantly reduces the time and effort
required in setting up or reconfiguring a desktop for users. This is particularly useful while
provisioning new desktops and applications.

ZENworks Personality Migration allows you to store the personality of a Windows user and migrate
the personality to another Windows user. For enterprise-scale migrations, you can use ZENworks
Configuration Management to distribute Directive bundles to store and apply personality settings to
the users.

The Personality Migration utility is provided with ZENworks Configuration Management. For more
information on installing the utility, see Chapter 2, “Installing ZENworks Personality Migration,” on
page 11.

The utility allows you to:
¢ Store the personality of one or more users on a Windows device to a compressed and password-
protected personality file.
+ Apply the personality settings from a personality file to a Windows desktop.

¢ Directly migrate the personality data from the desktops of one or more users on a Windows
device to the users on another Windows device without any intermediate file, if the two devices
are interconnected.

Review the following sections:

¢ Section 1.1, “Migrating User Accounts,” on page 8

¢ Section 1.2, “Migrating System Settings,” on page 8

¢ Section 1.3, “Migrating Application Settings,” on page 8
¢ Section 1.4, “Migrating Files and Folders,” on page 9

What Is Novell ZENworks Personality Migration?
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1.2

1.3

Migrating User Accounts

ZENworks Personality Migration allows you to migrate the user profiles for the user who has logged
on to the device, or for multiple users. You can select the local users or domain users whose
personalities you want to migrate. You can also map the users to apply the personalities. You can
apply these personalities to a single user or multiple users.

Migrating System Settings
You can migrate the following system settings:

¢ Accessibility
¢ Appearance

¢ Date and regional Settings

*

Keyboard, mouse, and other hardware
¢ Network settings

+ Sounds and multimedia

For a detailed list of the settings, see Appendix D, “Supported Settings in Personality Migration,” on
page 53.

IMPORTANT: You can migrate the network settings only in the File mode. For more information, see
Appendix B, “Troubleshooting Personality Migration,” on page 43

Migrating Application Settings
You can migrate the application settings of products belonging to the following companies:

¢ Adobe

¢ America Online
+ Corel

* GAIM

+ IBM

¢ Macromedia

¢ Microsoft

¢ Mozilla

¢ OpenOffice.org
¢ Palm

¢ Qualcomm

¢ Research in Motion

¢+ Sun

For a detailed list of the applications, versions, and settings, see Appendix D, “Supported Settings in
Personality Migration,” on page 53.

ZENworks 11 SP2 Personality Migration Reference



1.4 Migrating Files and Folders

You can select to migrate files, file types, or folders. You can also select the location on the destination
device to store these files and folders.

What Is Novell ZENworks Personality Migration?
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2.1

2.2

Installing ZENworks Personality
Migration

You can run Novell ZENworks Configuration Management Personality Migration on a Windows
workstation. ZENworks Personality Migration allows you to migrate personality from a Windows
device to another Windows device.

¢ Section 2.1, “System Requirements,” on page 11

¢ Section 2.2, “Prerequisite,” on page 11

¢ Section 2.3, “Installing ZENworks Personality Migration on Windows,” on page 12

¢ Section 2.4, “Installing ZENworks Personality Migration by Using ZENworks Bundles,” on
page 12
¢ Section 2.5, “Installing the ZENworks Personality Migration Core,” on page 12

¢ Section 2.6, “Installation Options,” on page 13

System Requirements

ZENworks Personality Migration is supported on the following platforms in Microsoft Windows:

¢ Windows 2000 Professional SP4 (only the 32-bit operating system version)
+ Windows Vista (both 32-bit and 64-bit operating system versions)

¢ Vista SP1 (both 32- bit and 64-bit operating system versions)

+ Windows XP Professional SP2 (only the 32-bit operating system version)
¢ Windows XP Professional SP3 (only the 32-bit operating system version)

+ Windows 7 (both 32-bit and 64-bit operating system versions on Professional, Ultimate, and
Enterprise editions)

To successfully store a personality to a device, the device must have at least double the amount or
greater free disk space than the size of the personality being stored.

For example, to successfully store a personality of 1 GB, the device on which you are storing the
personality must have a free disk space of at least 2*1 GB or greater.

Prerequisite

Before installing ZENworks Personality Migration, you need to install the corresponding Microsoft
Visual C++ 2008 redistributable package.

Installing ZENworks Personality Migration 11



2.3 Installing ZENworks Personality Migration on Windows

1 In your Web browser, access the following URL:
http://zenworks_primary_server_id/zenworks-setup/?pageld=tools.

The zenworks_primary_server_id is the IP address of the ZENworks Primary Server from where
you want to download the Personality Migration utility.

2 Download ZENworksPersonal ityMigration.exe to a temporary location.

3 Run ZENworksPersonal ityMigration.exe and follow the on-screen prompts to install it on
your workstation.

2.4 Installing ZENworks Personality Migration by Using
ZENworks Bundles

1 In your Web browser, access the following URL:
http://zenworks_primary_server_id/zenworks-setup/?pageld=tools.

The zenworks_primary_server_id is the IP address of your ZENworks Primary Server from where
you want to download the Personality Migration utility.

2 Download ZenworksPersonal ityMigration.exe to a temporary location.

3 Create a Windows bundle with an Install File(s) action by using the
ZenworksPersonal ityMigration.exe file located on the ZENworks server. Specify a
destination folder on the managed device to install this file.

For example, you can specify the destination folder as C:\Install.

4 Add a Launch Executable action in the install set of the bundle that you created. In the General
tab, specify the path where the ZENworksPersonalityMigration.exe file is located on the
managed device in the Command option.

For example, if the ZENworksPersonal ityMigration.exe file is located in C:\Install on the
managed device, then the path is C:\Instal INZENworksPersonalityMigration.exe.

5 In the Command Line Parameters, enter /quiet to install Personality Migration without user
intervention.

6 Click the Advanced tab, then do the following:
6a Set the Wait before proceeding to next action to When action is complete.
6b Set the Executable security level to Run as secure system user.

7 Assign this bundle to the managed device.

2.5 Installing the ZENworks Personality Migration Core

You can migrate a personality either by using a graphical user interface or by using a command line.
To use the command line option, you need the ZENworks Personality Migration Core. The graphical
user interface option and the Core option are installed automatically when you install ZENworks
Personality Migration, or you can choose to install only the Core option.

You can install the ZENworks Personality Migration Core separately by using the
ZenworksPersonal ityMigration.exe /coreonly command. For more information, see Section 2.6,
“Installation Options,” on page 13.

12 ZENworks 11 SP2 Personality Migration Reference



2.6

Installation Options

The following table lists the options that can be used with the ZenworksPersonalityMigration.exe

command:

Table 2-1 Installation Options

Option Description

1? Displays help and the available options

/passive Displays the progress of installation; does not require user intervention

/quiet Installs Personality Migration silently without the graphical user interface
/uninstall Uninstalls ZENworks Personality Migration

/coreonly Install ZENworks Personality Migration without using the Graphical User Interface
[repair Repairs the installed version of ZENworks Personality Migration

IMPORTANT: The options listed are case sensitive.

Installing ZENworks Personality Migration
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3.1

3.2

Uninstalling Personality Migration

You can uninstall Personality Migration in any of the following ways:
¢ Section 3.1, “Uninstalling Personality Migration by Using the
ZENworksPersonalityMigration.exe file,” on page 15

¢ Section 3.2, “Uninstalling Personality Migration by Using the Command Line Utility,” on
page 15

¢ Section 3.3, “Uninstalling Personality Migration by Using Windows Add or Remove Programs,”
on page 16

IMPORTANT: Before uninstalling Personality Migration, ensure that you close the Personality
Migration application and the Personality Migration template builder.

Uninstalling Personality Migration by Using the
ZENworksPersonalityMigration.exe file

1 Go to the location where the ZENworksPersonalityMigration.exe file is located and double-
click the file.

2 On the Welcome to ZENworks Personality Migration Setup page, click Next.
3 Select Remove, then click Next.

Uninstalling Personality Migration by Using the Command
Line Utility
1 At the Windows command prompt, go to the location where the
ZENworksPersonal ityMigration.exe file is located.
2 Run the ZENworksPersonalityMigration.exe /uninstall command.
or
To perform a silent uninstallation, run the following command:

ZENworksPersonalityMigration.exe /uninstall /quiet

Uninstalling Personality Migration 15



3.3 Uninstalling Personality Migration by Using Windows Add
or Remove Programs

1 On the desktop, click Start > Settings > Control Panel > Add or Remove Programs.

2 In the Add or Remove Programs window, select ZENworks Personality Migration, then click
Remove.

16 ZENworks 11 SP2 Personality Migration Reference



Manually Migrating Personality Settings

ZENworks Personality Migration allows you to store a user’s personality and migrate the personality
from a Windows device to another Windows device.

To manually migrate the personality settings, perform the following tasks in the order listed:

¢ Section 4.1, “Storing a User’s Personality Settings and Data,” on page 17
¢ Section 4.2, “Applying a User’s Personality Settings and Data,” on page 23

4.1 Storing a User’s Personality Settings and Data

1 Before beginning the migration process, do the following:

03 Ensure that the ZENworks Personality Migration is installed on the source device. For more
information, see Section 2.3, “Installing ZENworks Personality Migration on Windows,” on
page 12.

O Close the applications whose settings you want to migrate. (You are also prompted to close

any open applications upon launching ZENworks Personality Migration).

O If you are migrating system settings and user settings across interconnected devices
without using an intermediate file, you must make sure that the Windows Firewall has been
enabled to treat the Personality Migration software as an exception, so applications can
interact with each other. For more information, see “Enabling ZENworks Personality
Migration through the Windows Firewall” on page 21.

0 If you want to migrate personality for multiple user accounts on the device, then login as a
user with administrator privileges.

2 Use one of the following methods to launch ZENworks Personality Migration:
¢ Double-click the ZENworks Personality Migration shortcut icon on the desktop.
¢ Click Start > All Programs > Novell ZENworks > ZENworks Personality Migration.

Manually Migrating Personality Settings 17



B ZENworks Personality Migration
Novells ZENworkse

@ ZENworks= Personality Migration N

‘welcome to ZEMworks Personality Migration, The ZEMworks Personality Migration wizard guides you to
successFully migrate settings data of a swstem,

Select the operation you want to perform. IF this is wour old machine, choose Store. IF this is the new
machine choose Apply.

(%) Stare

Collect settings and data From this computer to move ko another computer,

N O Apply

Transfer settings and data collected from another computer to this computer,

ZENworkse
Personality
Migration

3 Click Store to store the user account information, system settings, application settings and data
of the source system to a PNP (Platform Neutral Package) file.

NOTE

The PNP file created to store the 32-bit version Microsoft Outlook settings on Windows 7 is not
backward compatible with lower versions of Personality Migration.

4 Click Next to search the source system for the user information and the installed applications
whose settings you can migrate.This can take several minutes.

B ZENworks Personality Migration
Novells ZENworkss

@ ZENworkss Personality Migration N

By default, all users with walid profiles are selected, Deselect the accounts whaose user information you
do not wank ko skore,

Source

n Local Users
81 blradmin
* 81 danju

ZENworkss
Personality
Migration

[ Cancel ][ < Back ][ Mext =
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By default, all the user accounts listed are selected.

5 Deselect the user account whose settings you do not want to migrate

6 Click Next to deselect the system settings you do not want to migrate.

Novelle ZENworkse

B ZENworks Personality Migration

(l_]) ZENworkse Personality Migration

ZENworkss
Personality
Migration

System settings that can be migrated are listed. Deselect the settings that vou do nok want to migrate.

Source
Acceszzibily
6 Accessibility

Appearance
} Appearance
@’ Desktop Icons
| Falder Options
(=4 Fonts
8 screen saver
B, Taskbar
S wallpaper

Command

B —ommand

< i | 3

e

[ Cancel

][ < Back. ][ Mext =

]

7 Click Next to deselect the application settings you do not want to migrate.

B ZENworks Personality Migration

Novelle ZENworkse

ZENworkss
Personality
Migration

(l_]) ZENworkse Personality Migration

Application settings that can be migrated are listed. Deselect the settings that you do not want ko
migrake.

Source
Adobe
il Adobe Acrobat Reader
[ Adobe ImageReady

Macromedia
@ Macromedia Drearmweaver

Messzenger
@ Movell Groupwise Messenger

Microsolt
Microsoft Access
Micr osoft Excel
Microsoft Fronkpage
ﬁ Microsoft Internet Explorer

@ T2 W i L T Ty

< i | 3

|

[ Cancel ][ < Back ][ Mext =

]

8 Click Next to deselect the files and folders you do not want to migrate.

Manually Migrating Personality Settings
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B ZENworks Personality Migration
Novells ZENworks

‘\—.‘i’ ZENworkss Personality Migration N

Files and Folders that can be migrated are listed, Deselect folders that you do nok wank ko migrate. You
may also store files based on their file bype. Select 'Excluded Items' to filker your file selection.

Source

|9 Ci\Documents and SettingstAdministratoriDeskbop,
|23 C:\Documents and Settings! Administratoriiy Documents) add Folder
|3 C:\Documents and Settingstall Users\Deskkop), —
|23 C:\Documents and Settingsiall UsersiDocuments, #dd File Tvpe

add File

Remove Ttem

N
ZENworkss
Personality
Migration
< | =
[ Cancel ][ < Back ][ Mext = ]

This page also enables you to add files, folders or files of a particular type to the list of migration
files.

9 (Optional) Click Add File to add a file to migrate. The added file is listed in the Source column.

10 (Optional) Click Add Folder to add a folder to migrate. The added folder is listed in the Source
column.

11 (Optional) Click Add File Type to specify the types of files you want to migrate.

12 (Optional) Click Remove Item to remove the highlighted item from the list of items to be
migrated.

13 (Optional) Click Exclude Item to exclude any files and folders you do not want to migrate.

14 Click Next, then select the mode to transfer the settings and data. You can transfer the data either
by Direct mode or File mode.

¢ Direct: Provides real-time migration of settings and data between systems in the same
subnet.

IMPORTANT: Do not migrate network settings in the Direct mode. For more information,
see Appendix B, “Troubleshooting Personality Migration,” on page 43. Alternatively, you
can migrate the network settings in the File mode.

Continue with Section 4.1.1, “Transferring Data by Using Direct Mode,” on page 21.

¢ File: Stores the migration settings and data in a PNP file. Specify the filename or click
Browse to browse to and select the file to store the settings and data.

Continue with Section 4.1.2, “Transferring Data by Using File Mode,” on page 22.
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4.1.1 Transferring Data by Using Direct Mode

1 You must have performed Step 1 to Step 13 in Section 4.1, “Storing a User’s Personality Settings
and Data,” on page 17.

2 Be sure that ZENworks Personality Migration is enabled through the Windows Firewall. If it is
not enabled, see “Enabling ZENworks Personality Migration through the Windows Firewall” on
page 21.

3 Select Direct, then click Next. The source system waits for the destination system to connect.

8 ZENworks Personality Migration
Novells ZENworks |

‘IJ_‘ ZENworkss Personality Migration N

Select the mode ko transfer the settings and data.

(3 Direct

Transfers settings and data directly betwesn computers, Chaoss this aption f your computers are
connected with a cable or over a nebwork.

OFie

Save settings and data ko  PNP file on & hard drive or nebwork drive. Chaose this optian if you wil
be burning the data ta a COD ar DVD.

Select Advanced for aptions to control the size of the stred files or to password pratect your data,

ZENworks
Personality
Migration

[ cancel | [ <Back [ Mewt

4 On the destination system where ZENworks Personality Migration is installed, select the source
system whose settings and data you want to apply.

5 Click Next to apply the settings and data on the destination device.

Continue with Step 6 in Section 4.2, “Applying a User’s Personality Settings and Data,” on
page 23.

Enabling ZENworks Personality Migration through the Windows Firewall

If you are migrating personalities across devices on a network by using the Direct mode, you must
enable the Windows Firewall to detect certain exceptions.

1 Click Start > Settings > Control Panel.

2 Double-click Windows Firewall to open the Windows Firewall dialog box.
3 Click the Exceptions tab.
4

In the Programs and Services list, check to see if ZENworks Personality Migration and ZENworks
Personality Core exceptions are available and selected. If they are, proceed to Step 7.

ol

If the exceptions are not available in the Programs and Services list, then click Add Program.

6 Browse to the Personality Migration installation folder and select the
PersonalityMigration.exe and PersonalityMigrationCore.exe files.

7 Click OK.
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4.1.2 Transferring Data by Using File Mode

1 You must have performed Step 1 to Step 13 in Section 4.1, “Storing a User’s Personality Settings
and Data,” on page 17.

2 Select File.

& ZENworks Personality Migration
Novells ZENworks

(_l_g) ZENworkse Personality Migration N

Select the mode ta kransfer the settings and data.

) Direct

Transfers settings and data directly between computers, Choose this option if your computers are
connected with a cable or over a nebwark.

@Fie

Save settings and data to a PP file on & hard drive or network drive. Choose this option iF vou wil
be burning the data ko a CD or DVD.

Select Advanced for options ko contral the size of the stored files or to password protect your data,

|ments and Settings\dan]u‘BLR-><P-N\Desktup\ZENworl@PersonahtyMigration‘pnp‘ l Browse. ..
ZENworks
Personality
Migration
Cancel ] [ < Back ][ Next =

3 Click Advanced to display the Advanced File Options dialog box.

B Advanced File Options E|EIE|

Span to multiple files: Afthe following size  w

Use the following passwordg

ZENworks Personality Migration can store the settings and data from your system in multiple
files. By default, it creates 650 MB files. The maximum span size is 2 GB. The Span to multiple files
option allows you to control the size of the Personality Migration output files.

The Password to encrypt the PNP file option password protects the data files that Personality
Migration generates. You are prompted for the password when you apply the settings on the
destination machine.

4 Click OK to close the Advanced File Options dialog box.
5 Click Next to display the progress of the settings and files being stored.
6 Click Next to review the results. The errors are displayed in red color.

7 Click Finish to complete the store process.
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4.2 Applying a User’s Personality Settings and Data

1 Ensure that Personality Migration is installed on the destination device. For more information,
see Section 2.3, “Installing ZENworks Personality Migration on Windows,” on page 12.

2 Use one of the following methods to launch ZENworks Personality Migration on the system as
follows:

¢ Click the ZENworks Personality Migration shortcut icon on the desktop.

¢ Click Start > All Programs > Novell ZENworks > ZENworks Personality Migration.

B ZENworks Personality Migration
Novelle ZENworkse

@ ZENworks= Personality Migration N

elcome to ZEMworks Personality Migration. The ZEMworks Personality Migration wizard guides wou to
successfully migrate settings data of a swstem,

Select the operation you want ko perform. IF this is vour old machine, choose Store. IF this is the new
machine choose Apply,

() Stare

Collect settings and data from this computer ko move to another computer.

N (& Apply

Transfer settings and data collected from another computer to this computer,

ZENworks«
Personality
Migration

3 Click Apply to apply the saved settings and data on the device.

4 Click Next, then select the mode to transfer the user’s personality settings and data:
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& ZENworks Personality Migration |:”:|[z|
Novelle ZENworks= |

(__ls_’ ZENworkss Personality Migration N

Choose how ko move the settings and data to this computer.

(%) Direct
A

Apply settings and data directly From another computer.

| v

()File

Apply the settings and data stared in a file. Use Browse to find the PNP with the stored settings and

N data.

ZENworkss
Personality
Migration

Browse. ..

[ Cancel ][ < Back ] Mext =

Direct: Provides real-time migration of settings and data between systems in the same
subnet. The utility identifies and lists all the machines in the network that are ready to
migrate their personalities. Continue with Step 5.

NOTE: Direct Migration is supported only from 32 bit to 32 bit machines on the same
subnet.

File: Uses the migration settings and data stored in a PNP file. Click Browse to browse to
and select the PNP file saved during the store operation. Skip to Step 7.

5 Select the source system whose settings and data you want to apply.
6 Click Next, then to select one of the following transfer options:

¢ Typical: Lets you migrate all the selected settings and data of the user's profile from the

source system to the destination system. If the user’s account does not exist on the
destination system, it is newly created with a blank password, if the administrator is logged
in to the destination system. If the administrator is not logged in to the destination system,
the selected settings are migrated to profile of the user who has logged in to the destination
system.

Skip to Step 13.

Custom: Lets you customize the personality settings and data before migrating to the
destination system. You can choose to migrate the personality to different users or create
new users on the destination system. Continue with Step 7.

7 Click Next.
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& ZENworks Personality Migration |:”:I[z|
Novells ZENworks

(__lg_’ ZENworkss Personality Migration N

Deseleck the users whose account information vou do not want to apply, IF there are multiple users on
this machine, you can use the drop down menu ko change the destination user account.

Source Drestination
’ Local Users
A &4 Hlradrin &1 blradmin w
&4 danju Do Mok Apply

184 blradmin

N

ZENworkss
Personality
Migration

The Source column lists the user account information that was stored in the PNP file.
The Destination column lists the user accounts available on the current device.

If the administrator is logged in to the destination device, and the source user does not exist on
the destination device, the source user account is automatically created on the destination device
with a blank password.

IMPORTANT: The source user account is not created on the destination device if the Password
Complexity policy is enabled on the destination device.

If the administrator is not logged in to the destination device, the selected settings are migrated
to the profile of the user who has logged in to the destination device.

You can also do any of the following in the Destination column:
¢ Select an existing user account to apply the personality settings to a different user.
For example, you can apply the personality settings of blradmin to the Guest user.

¢ Click Create a new user to create a new user account and apply the personalized settings to
this newly created user. You are prompted to enter the username and the password for the
new user.

NOTE

If the Password Complexity policy is enabled on the destination device, ensure to specify a
password that matches the Password Complexity policy of the destination device.

Click Next. Deselect the system settings you do not want to migrate.
Click Next. Deselect the application settings you do not want to migrate.

(Optional) Double-click the application name in the Destination column and select a different
application if you want to apply the personality settings across applications. For example, you
can apply the FireFox bookmarks and settings to Internet Explorer or vice versa.

Click Next. Deselect the files settings you do not want to migrate.
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12 (Optional) Double-click the filename in the Destination column to change the destination of the
file.

13 Click Next to migrate the selected settings to the destination device. This step might take some
time, depending on the amount of data migrated.

14 Review the results of the migration. Errors, if any, appear in red color.
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5.1

Automatically Migrating Personality
Settings

ZENworks Personality Migration provides automated migration for large-scale personality
migrations from a Windows managed device to another Windows managed device across an
enterprise.

To automatically migrate the personality settings, perform the following tasks in the order listed:

¢ Section 5.1, “Creating a Personality Template,” on page 27

¢ Section 5.2, “Modifying an Existing Template,” on page 38

*

Section 5.3, “Automatically Migrating Personality Settings,” on page 38

*

Section 5.4, “Migrating Personality Settings by Using the Command Prompt,” on page 39

*

Section 5.5, “Command Prompt Options to Store and Apply Personalities,” on page 40

Creating a Personality Template

Personality Migration uses a template to perform automated migrations by using the directive
bundles. This provides an efficient migration method without stepping through the ZENworks
Personality Migration user interface each time you want to perform a migration on a specific
machine. Ensure that you use the same template for the store and apply process.

A template defines policies that describe to the ZENworks Personality Migration engine the
migration rules for the following settings categories:

¢ Users

¢ System Settings

¢ Application Settings

¢ Files and Folders

The template communicates which items are to be saved from the source Windows machine into the
PNP file, and which items are to be applied to the destination machine.

A template is an XML file that can be read and edited with any editor. However, using the Template
Builder for ZENworks Personality Migration is a convenient way to build custom templates for
migrations, so you can have standardized and consistent migration across an organization.You can
create templates using the Template Builder.
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5.1.1 Starting the Template Builder

1 On a supported Windows device, click Start > All Programs > Novell ZENworks > ZENworks
Personality Migration Template Builder.

5.1.2 Using the Template Builder to Create a Template

The Template Builder consists of four tabs in addition to standard File options such as New, Open, and
Save.

1 Open the Template Builder to display the default Users tab.

The Users tab options control template information for the user migration.

& 7ENworks Personality Migration Template Builder E”§|fg|
File:

DeEHE &

Swstemn | Applications | Files

® Migrate the settings for the currently logged in user
() Migrate the settings for all users
O Add users to migrate

Source Drestination

2 Select one of the options described in the following table, depending on whether you want to
migrate one user, all users, or a selected list of users.

Option Description

Migrate the settings for Migrates the settings for the currently logged in user to another logged in user.
the currently logged in
user

Migrate the settings for Migrates all the settings selected in the template for all the user profiles in the
all users system. Click Exceptions to list users you want to exclude from migration.

Add User: Lets you select all the local users, the domain users, or a specific
user to be excluded from migration. For example, if you do not want to migrate
the administrator settings from any of the systems targeted for migration, click
Add User, select The following user option, specify administrator, then click OK.

Delete User: Lets you remove the user from the list of users excluded from
migration.
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Option Description

Add users to migrate This option allows you to explicitly list the profiles to migrate.

Add User: Lets you select all the local users, the domain users, or a specific
user to be migrated.

You can also map a username on the source machine to a different username
on the destination machine:
1. Click Add User.

2. Click The following user option and specify the username. Ensure that the
username is a valid account on the host machine, such as userl.

3. Click OK to display the username in the Source column.

£ ZENworks Personality Migration Template Builder E”§|E‘
File:

bDed &

Users | Spstem | Applications | Files

) Migrate the settings for the curmently logged in user

J Migrate the seftings for all users
o 9

@) Add users to migiate addUser. | [ Delete User

Source Destination
Local Users
Al local users

Create User Mamed "userl" v

4. From the drop-down list, click the destination of the newly added user
displayed as Create User Named “username” by default. For example,
Create User Named “userl”. The user’s account is created with a blank
password on the destination device.

IMPORTANT: The source user account is not created on the destination
device if the Password Complexity policy is enabled on the destination
device.

or

Select the Create New User option, and specify the username and the
password to be created on the destination machine to which you want to
migrate the personality settings. If the Password Complexity policy is
enabled on the destination device, the password that you specify should
match the password complexity of the destination device.

5. Click OK.

Delete User: Lets you remove the user from the list of users to be migrated.

3 Click the System tab, then deselect any settings you do not want to migrate.
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2 ZENworks Personality Migration Template Builder
File:

O &

Users | Swstemn | Applications | Files

Select the system settings you want to migrate:

Source

|

Appearance
Appearance
Desktop lcons
Folder Options
Fants
Screen Saver
Taskbar
‘wallpaper

Command
Command

Date and Regional 5 etings
Date and Time
Regional Settings

<€

Keyboard. Mouse and other Hardware
Ly NP [ [

The System tab controls the system settings to be migrated for each of the user accounts selected
in the Users tab. By default, all the settings are selected.

To deselect all the options, right-click the Source panel and select the Uncheck All option. To
select all the options in the Source panel, right-click and select the Check All option.

4 Click the Applications tab to display the list of all the applications you can migrate.

2 ZENworks Personality Migration Template Builder
File:

DE Wl (@
Users | System | Applications | Files

Select the application zettings and the destination to which you want to migrate the settings:

Source Destination

|

Microgoft word
MSN Messenger

Mozilla

Thunderbird

OpenDifice.ong

Openiffice. org \Witer

Microzaft Wword
MSM Messenger

Firefox

Firefiox
Microzoft Internet Explorer

OpenQffice.org \Writar

PalmDesktop
Palm Desktop Palm Desktop
Qualcomm B
Eudara Eudara

|

To deselect all the options, right-click the Source panel and select the Uncheck All option. To select
all the options, right-click the Source panel and select the Check All option.
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5 Select an appropriate destination application from the drop-down list in the Destination column.
ZENworks Personality Migration supports the migration of the application settings between:

¢ Same applications of same version: Migrates settings between applications of the same
version.such as from Microsoft Office 2003 to Microsoft Office 2003.

¢ Same applications of different versions: Migrates settings from the source application to a
destination application of higher version. such as from Microsoft Office 2003 to Microsoft
Office 2007.

¢ Cross Applications: Migrates settings from the source application to a destination
application of similar type, such as from Internet Explorer to Firefox.

Before migration, ensure that the destination application is installed on the destination machine.
An application setting selected for migration is ignored if it is not available on the source
machine or the destination machine.

6 Click the Files tab to display settings for migrating data.

£ 7ENworks Personality Migration Template Builder
File

NS HE &

Users | Systemn Applications| Filez |

Select the files and the destination to which you want to migrate the files.
“You may migrate the filez bazed on the fle type. Uze Exclude ltems to filter your file zelection.

Source Destination Add File. .

Add Folder...
Add File Type...

[

5| E il Test o

Exzclude [tems...

The Files tab allows you to set the rules for the migration of data.

IMPORTANT: Do not select to migrate the entire temp folder to the destination. Select only
those files that you want to migrate. This is because the migration process utilizes the temp
folder, and selecting the entire folder for migration displays error messages.

7 Click Add File to add a file to migrate.

Automatically Migrating Personality Settings 31



2 ZENworks Personality Migration Template Builder
File:

DeHd &
Users | System | Applications | Files

Select the files and the destination to which you want ta migrate the files.
You may migrate the filez bazed on the file type. Use Exclude ltems to filer your file selection.

Source Drestination Add File...
7 E:Mrialsfile] Testodt
Add Folder....
Add File Type...

2 File to store:

Enter the file path you wish to store. or click Browse to select it You may use any of th

[E:Aialhfle Textodt | [ Browse..
] (o)

7a Click Browse to browse to and select the file you want to add for migration.
or

Click Variables to select a variable that maps to the location of the file you want to migrate.
For example, if you want to migrate a desktop file named test._txt, click the desktop
variable and append \test.txt to it.

If the variable is a directory, the path should end with a \ (backslash). For example, if you
want to migrate the desktop directory, the variable is %desktop%\.

For more information on variables, see Appendix E, “Understanding Variables,” on
page 63.

7b Click OK to list the file in the Source column.

7¢ Double-click the filename in the Source column to open the File Destination dialog box.
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2 ZENworks Personality Migration Template Builder
Filer
Ded @

Users | System | Applications | Files

Select the files and the destination ta which you want to migrate the files.
You may migrate the files bazed on the file tppe. Use Exclude Items to filker your file selection.

Source Drestination Add File...
| E:riahfile] T et odk
Add Folder....
2 File Destination g@ #dd File Type. ..
Source: |=£'_"?
Destination: || | [ Erawse... ] Ewclude Items. ..
% ) (oo

7d Click Browse to browse to and select the destination location for the file migration
or

Click Variables to select a variable that maps to the destination location. For example, if you
want to migrate the file named filel to the favorites directory, click the favorites variable
and append \filel to it.

If the variable is a directory, the path should end with a \ (backslash). For example, if you
want to migrate the desktop directory, the variable is %desktop%\.

For more information on variables, see Appendix E, “Understanding Variables,” on
page 63.

7e Click OK.
8 Click Add Folder to add a folder to migrate.
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2 ZENworks Personality Migration Template Builder
File:

Ded (@

Users | Systemn | Applications | Files

Select the files and the destination to which you want ta migrate the files.
You may migrate the filez bazed on the file type. Use Exclude ltems to filer your file selection.

Source Drestination Add File...
2 E:Mrialsfile] Test.odt
Add Folder....
Add File Type...

2 Folder to store:

Enter the folder path you wish to store, or click Browse to select it. You may use any
of the variables that ZEMworks Personality Migration provides in the path.

|E:\trial | [ Browse...
5 Coe

8a Click Browse to browse to and select the folder you want to add for migration.
or

Click Variables to select a variable that maps to the location of the folder you want to
migrate. For example, if you want to migrate a desktop folder testfolderl, click the
%desktop% variable and append \testfolderl to it.

If the variable is a directory, the path should end with a \ (backslash). For example, if you
want to migrate the desktop directory, the variable is %desktop%\.

For more information on variables, see Appendix E, “Understanding Variables,” on
page 63.

8b Click OK to list the folder in the Source column.

8c Double-click the folder name in the Source column to open the Folder Destination dialog
box.

34 ZENworks 11 SP2 Personality Migration Reference



2 ZENworks Personality Migration Template Builder,
File:

D& W (&

lzers | Spstem | Applicationg | Files

Select the files and the destination to which pou want to migrate the files.
‘f'ou may migrate the files based on the file type. Use Exclude ltems to filker your file selection.

Source Drestination Add File...

£ E:\rialfle? Test.odt

Add Folder...
Add File Type...
2 Folder Destination
Source; B
Exclude ltems...
Destination: | |[ Browse. ..
%] (o

8d Click Browse to browse to and select the destination location to migrate the folder.
or

Click Variables to select a variable that maps to the destination location. For example, if you
want to migrate the folder named folder1 to the programfiles directory, then click the
programfiles variable and append the \folderl name to it.

If the variable is a directory, the path should end with a \ (backslash). For example, if you
want to migrate the desktop directory, the variable is %desktop%\.

For more information on variables, see Appendix E, “Understanding Variables,” on
page 63.

8e Click OK.
9 Click Add File Type to add the types of files you want to migrate.
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2 ZENworks Personality Migration Template Builder,
File:

Dl (&

sers | Spstern | Applications | Files

Select the filez and the destination to which you want to migrate the files.
f'ou may migrate the files based on the file type. Use Exclude ltems to filker pour file selection.

Source
£ E:Mrialfilel Textodt

Destination

Add File...

(55 E - Mhrial's

=1
| Browse...

Add...

2 File Types

In Folder: |Local Hard Drives [C:E:)

@}:I Audio ~
[C1%8] Microzsoft Excel Documents
[(JE Microsoft Powerpaint Documerits =
[ Microscit ‘word Documents
DE OpenOffice.org Cale Documents
e - e ' = .
<)

|

u] ] [ Lancel l

I

Add Folder....
Add File Type...

Remove ltem

Exclude ltems...

9a In the In Folder field, type the name or click Browse to browse to and select the folder. By
default, all the local hard drives are displayed in this field.

9b (Optional) If you need to add a file type, click Add, then specify the file type, such as . INI.

9c Select the file types you want to migrate, then click OK to list the file types in the Source

column.

9d Double-click the file type in the Source column to open the File Type Destination dialog box.

2 7ENworks Personality Migration Template Builder
Fil=

DEHE @
I_l Users || System || Applications | Files

Select the files and the destination to which pou want to migrate the files.
rou may migrate the files based on the file type. Use Exclude Items to filker your file selection.

Source
£ E:\rialvile? Test.odt

|25) ExMbrialy
ol

2 File Type Destination

Drestination

CEX

Source: |(-):|

Destination: |

| [ Browse... ]

Ok

l [ Lancel

dd File...

Add Folder...

Add File Type...

Hemaove ltem

L

Exclude ltems...

A

9e Click Browse to browse to and select the destination location for the files.

or
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Click Variables to select a variable that maps to the destination location.

For more information on variables, see Appendix E, “Understanding Variables,” on
page 63.

9f Click OK.
10 (Optional) Remove any files or folders that you do not want to migrate.

10a In the Source column, highlight the item that you do not want to migrate.

Q ILENworks Personality Migration Template Builder E“E”zl
File:
0w W&

lzers | Spstem | Applicationg | Files

Select the files and the destination to which pou want to migrate the files.
‘f'ou may migrate the files based on the file type. Use Exclude Items to filker your file selection.

Source Drestination Add File...
& E:\rialfleT Test.odt
(2 ExMbrial, Add Folder...
Add File Type...

[ Bemove ltemn |

Ewxclude [tems...

10b Click Remove Item.
11 (Optional) Exclude any files and folders you do not want to migrate.

11a Click Exclude Items to display the Exclude Files and Folders dialog box.
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5.2

5.3

£ ZENworks Personality Migration Template Builder E||E|g|
File

D W (@

Usgers || Spstem Applications| Files |

Select the files and the destination to which pou want to migrate the files.
‘f'ou may migrate the files based on the file type. Use Exclude ltems to filker your file selection.

Source Drestination Add File...
& E:\rialfle? Test.odt
(23 E:Mkrial Add Folder...

& Exclude Files and Folders [Z”E|g|

Add File Type...
Select the files and folders you wish to exclude. You may also exclude files based on their
file type.
ii_'if‘ E:Mtrialyfilel Text.odt Add File. ..
Add Folder.. i Evclude ltems... |
Add File Type...

Remove ltem

&}

11b Select the options you want to use to exclude items:
¢ Add Files: Click Add File, then select the files to be excluded from the migration.
¢ Add Folder: Click Add Folder, then select the folders to be excluded from the migration.

¢ Add File Type: Click Add File Type, then select the types of files to be excluded from the
migration.

+ Remove Item: Click Remove Item to remove the item from the exclusion list and include
it in the migration.

11c Click OK.

12 Click File > Save to save the template as an .xml file.

Modifying an Existing Template
The ZENworks Personality Migration Template Builder also allows you to modify existing templates.

1 Click File > Open, then open the template you want to modify.
2 Make the required changes.
3 Save the template.

Automatically Migrating Personality Settings

Use directive bundles for enterprise-scale migrations of personality settings from a Windows device
to another Windows device. Before you begin the migration process, ensure that the ZENworks 11
SP2 Agent is installed on the device.

When you create bundles by using the Store Personality or Apply Personality actions, the bundles
always run as a dynamic administrator. For more information, see “Action - Launch Executable” in
the ZENworks 11 SP2 Software Distribution Reference.
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5.4

NOTE: You must not launch multiple personality migration bundles at the same time on the same
device. If you do so, the bundles are not launched correctly. The log of the bundle that was first
launched is the only log stored in the personalitylog.xml file. Also, the dynamic administrator
user profiles for the bundles are not deleted. You must manually delete them.

1 Create a Store Personality action.

For more information, see “Creating Bundles” in the ZENworks 11 SP2 Software Distribution
Reference.

2 Assign this bundle to a user or a device, whose user’s personality needs to be migrated.

For more information on assigning the bundle, see “Assigning Existing Bundles to Users” in the
ZENworks 11 SP2 Software Distribution Reference.

3 Create an Apply Personality action.

For more information, see “Creating Bundles” in the ZENworks 11 SP2 Software Distribution
Reference.

4 Assign this bundle to the user to whom you want to apply the personality.

For more information on assigning the bundle, see “Assigning Existing Bundles to Users” in the
ZENworks 11 SP2 Software Distribution Reference.

The personality settings are applied to the user on the destination system when the Apply
Personality action is launched.

IMPORTANT: After applying the personalities, reboot the devices for the personalities to take
effect. In order to ensure this, add the Reboot/Shutdown action to the bundle. For more
information, see “Creating Bundles” in the ZENworks 11 SP2 Software Distribution Reference.

Migrating Personality Settings by Using the Command
Prompt

Before beginning the migration process, do the following;:

(3 Ensure that the ZENworks Personality Migration is installed on the source device. For more
information, see Section 2.3, “Installing ZENworks Personality Migration on Windows,” on
page 12.

[ Close the applications whose settings you want to migrate. (You are also prompted to close any
open applications upon launching ZENworks Personality Migration).

To migrate the personality settings by using the command prompt:

1 Run the migration program as an administrator:
Method 1:

1. Open a command prompt in Windows by clicking Start > All Programs > Accessories. Right-
click Command Prompt, then click Run as Administrator.

2. Change to the ZENworks Personality Migration installation directory.
Method 2:

1. In the directory where you have installed Personality Migration, right-click the
PersonalityMigrationCore.exe file.

2. Click Properties > Compatibility.
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3. In the Privilege Level group, select Run the program as an administrator, then click OK.

4. Open a command prompt in Windows by clicking Start > All Programs > Accessories >
Command Prompt.

5. Change to the ZENworks Personality Migration installation directory.

2 On the source device, store the personality by using the following command:

PersonalityMigrationCore.exe --store --template=value --file=value

You can also use the password, span-size, no-span, and log options. However, these are optional.

For example,

PersonalityMigrationCore.exe --store --template=C:\template.xml --
file=C:\users.pnp --log=C:\users. log

For more information on options, see Section 5.5, “Command Prompt Options to Store and
Apply Personalities,” on page 40.

3 On the destination device, apply the personality by using the following command:

PersonalityMigrationCore.exe --apply --template=value --file=value

You can also use the password and log options. However, these are optional.

For example,

PersonalityMigrationcore.exe --apply --template=C:\template.xml --
file=C:\users.pnp --log=C:\users. log

For more information on options, see Section 5.5, “Command Prompt Options to Store and
Apply Personalities,” on page 40.

5.5 Command Prompt Options to Store and Apply Personalities

Table 5-1 Command Prompt Options

Option Description/Value

file The complete path and the name of the PNP file

template The complete path and the name of the template

span-size The size of spanned files in megabytes (MB)
The default span-size is 650 MB and the maximum span-size is 2 GB

no-span Migrates personalities without span

password The password to access the PNP file

with-options The filename in which the command line parameters are stored when a command
exceeds 256 characters

log The complete path and name of the log file
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A.2

Best Practices

The following sections explain the best practices to follow while using the Personality Migration
utility:

¢ Section A.1, “Storing and Applying Personalities,” on page 41
¢ Section A.2, “Setting the Length of the Computer Name,” on page 41

Storing and Applying Personalities

After changing any system settings, ensure that you restart your device before storing the
personality. Similarly, ensure that you restart your device before and after applying the personality.
This is because certain system settings are applied only after restarting the device.

Setting the Length of the Computer Name

The name of the computer on which you are storing the personality must be less than or equal to 15
characters. This is because the maximum number of characters that you can specify for a computer
name is set to 15 in NetBIOS.

Best Practices

41



42 ZENworks 11 SP2 Personality Migration Reference



Troubleshooting Personality
Migration

This section provides solutions to problems you might encounter while working with Personality
Migration:

¢ “The network connection is lost while using Direct mode to migrate network settings from the
source device to the destination device when both the devices are in the same subnet” on
page 43

¢+ “How do I enable debug logging for settings migration in Personality Migration?” on page 43
¢ “Where do I find the Personality Migration log files?” on page 44
¢ “The Personality Migration application hangs” on page 44

¢ “Migration of the archive.pst file from a customized location in Microsoft Outlook fails” on
page 44

¢ “An error message is displayed when you use bundles to store or apply the Microsoft Outlook
settings” on page 44

¢ “Where do I find the Personality Migration log files for Microsoft Outlook?” on page 44
¢ “Unable to open Microsoft Outlook after storing the Outlook settings” on page 45

The network connection is lost while using Direct mode to migrate network
settings from the source device to the destination device when both the devices
are in the same subnet

Source: ZENworks Configuration Management; Personality Migration.

Explanation: Do not migrate the network settings from the source machine to the destination
machine in Direct mode. This is because the destination machine obtains the
same network settings as the source machine, so it disconnects from the source
and stops the migration process.

Action: Use File mode to migrate network settings.

Action: If you are required to use Direct mode to perform the migration, deselect the
Network Settings option.

How do | enable debug logging for settings migration in Personality Migration?

Source: ZENworks Configuration Management; Personality Migration.

Action: Inthe ZENworksPersonalityMigration_Installation_Path\App.configfile,
set the value of the Enable_Debug parameter to True. The default value is False.
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Where do | find the Personality Migration log files?

Source:

Action:

ZENworks Configuration Management; Personality Migration.

If Personality Migration is executed as a standalone application you can find the
PersonalityMigration*.xml log file in the following location:
%appdata®\Novel I\Personal ityMigration\PersonalityMigration\11.2.0
.X

If Personality Migration is executed by using the Store/Apply Action through
ZENworks Configuration Management you can find the PersonalitylLog.xml
file in the

ZENworks_Configuration_Management_Installation_Path\Novel I\Zenwor
ks\Logs\Personal ityMigration directory on your device.

The Personality Migration application hangs

Source:

Explanation:

Possible Cause:

Action:

ZENworks Configuration Management; Personality Migration.

If you try to uninstall Personality Migration when the application is still open,
the application hangs. A dialog box appears that allows you to either Exit,
Cancel, Ignore, or Retry the uninstallation process.

You clicked Ignore.

Before uninstalling Personality Migration, ensure that the Personality Migration
application is closed.

For more information on how to uninstall Personality Migration, see Chapter 3,
“Uninstalling Personality Migration,” on page 15.

Migration of the archive.pst file from a customized location in Microsoft Outlook

fails

Source:

Possible Cause:

Action:

ZENworks Configuration Management; Personality Migration.

You stored or applied the Microsoft Outlook settings from a non-administrator’s
account.

Store and apply the Microsoft Outlook settings from an administrator’s account.

An error message is displayed when you use bundles to store or apply the
Microsoft Outlook settings

Source:

Explanation:

Action:

ZENworks 11 SP2; Personality Migration.

After you use bundles to store or apply the Microsoft Outllook settings using
bundles, the following error message is displayed when you start Microsoft
Outlook: Cannot start Outlook.

To resolve this issue, run the <Office Installation path >\outlook.exe /
resetnavpane command.

Where do | find the Personality Migration log files for Microsoft Outlook?

Source:

ZENworks 11 SP2; Personality Migration.
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Action: When a 32-bit version of Microsoft Outlook is installed on a Windows 7 64-bit
machine:

¢ If Personality Migration is executed as a standalone application, you can
find the PersonalityMigration*_outlook.xml log file in
%appdata’\Novel I\Personal ityMigration\PersonalityMigration\11
.0.0.x.

¢ If Personality Migration is executed by using the Store/Apply Action
through ZENworks Configuration Management, you can find the
PersonalitylLog_outlook.xml file in the
ZENworks_Configuration_Management_Installation_Path\NovelI\Ze
nworks\Logs\Personal ityMigration directory of your device.

Unable to open Microsoft Outlook after storing the Outlook settings
Source: ZENworks 11 SP2; Personality Migration.

Explanation: When you use the ZENworks Personality Migration tool to store the settings for
Microsoft Outlook and then you try to open Microsoft Outlook, the following
error message is sometimes displayed:

Cannot open your default e-mail folders. The information store
could not be opened.

After you store the personality, Microsoft Outlook might not open in Offline
mode.

Action: Perform the following steps.
1 Go to Control Panel > Mail Settings > Show Profiles > Select Profile >

Properties > Data Files > Settings > Manually Control Connect State.

2 Select Connect with the network.
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Migration Settings

If you have installed Personality Migration as a standalone application, the following settings can be

migrated only by an administrator:

Table C-1 Settings for Administrators to Migrate

Type Settings

System Settings Fonts
Fontinstall
FontDPI
SystemFonts

Microsoft Outlook Settings

Microsoft Windows Login Screen Settings

Microsoft Publisher Application Settings

Mouse pointer

DefaultConnectionName (Internet Explorer,
Connections)

ResetTimeServer
ResetFileServer

SoundFilesLocation (Sound files for default settings)

TimeZone
AutoAdjustForDSTIsSet
AutoAdjustForDST
SyncSettings (Auto time sync)
NTPSync

NTPServerAddress
DefaultNTPServer
UseSimpleFileSharing

Trash (Recycle Bin option)

Archive.pst file

EnableFastSwitching
WelcomeScreen
LoginBackgroundColor
WelcomeScreenPictures
PasswordHints

ResearchParentalControlPassword
DisableNonFilteredResearchSites

Migration Settings
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C1l

Cl1

C.l1l2

Type Settings

Network Settings NetworkCards
DNS
IPFilterSecurity
HostsFile
LMHostsFile

Power and Energy Settings EnableHibernate
GlobalPowerPolicy

Files and Registries Settings System files
All user documents
All mounted and unmounted registries

Migrating E-mail Accounts and Profiles

Migrating Profiles

To migrate the Exchange Server User/Profile from source Microsoft Outlook to destination Microsoft
Outlook 2007, perform the following steps:

1 Create a profile in Microsoft Outlook.

2 Log into Microsoft Outlook using the profile account created in Step 1.

3 Change the settings that you want to migrate.

4 Start the migration.

User/Profile is migrated from source Microsoft Outlook to destination Microsoft Outlook 2007 along
with the selected settings.

NOTE:
¢ To migrate multiple Users/Profiles, see Appendix F, “Cross-User Migration Scenarios,” on
page 67.

+ Edit the hosts file under C:/Windows/System32/Drivers/etc path on both the source and des
tina ion devices by giving the IP address and FQDN.

Migrating Advanced E-mail Options

To migrate the available Advanced E-mail options, perform the following steps:

1 In Microsoft Outlook, click Tools > Options > Preferences > E-mail Options > Advanced Email Options.
2 Select the settings that the you want to migrate.

3 Change the settings that you want to migrate.

4 Start the migration.

All the selected settings are migrated from source Microsoft Outlook to destination Microsoft
Outlook 2007.
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C.2

C21

C.2.2

C.3

Personalizing Outlook

Nick Name Cache

To migrate the Nick Name Cache for Exchange Server User/Profile, perform the following steps:

1 Create a profile in Microsoft Outlook.
2 Log into the Microsoft Outlook using the Profile account.
3 Send e-mails to various e-mail addresses, so that the name gets stored in cache.

4 Start the migration.

In the destination Microsoft Outlook, log in with the same user/profile account. As you type the e-
mail address, the relevant e-mail addresses from the cache are auto-populated.

Reading Pane

To migrate the available Reading Pane options, perform the following steps:
1 In Microsoft Outlook, click Tools>Options>Others>Reading Pane.
2 Select the settings that the you want to migrate.
3 Change the settings that you want to migrate.
4 Start the migration.

To change the Reading Pane Location settings:

1 Click View>Reading Pane.

or

Click View>Arrange By>Custom>Other Settings.
2 Select the settings that you want to migrate.

3 Start the migration.

All the selected settings are migrated from source Microsoft Outlook to destination Microsoft
Outlook 2007.

Migrating Custom Views

To migrate the Custom View options, perform the following steps:

1 In Microsoft Outlook, click View>Arrange By>Custom.
2 Select the settings that you want to migrate.

3 Start the migration.

All the selected settings are migrated from source Microsoft Outlook to destination Microsoft
Outlook 2007.

Migration Settings
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C4

Cb5

C.6

Migrating Rules and Alerts

To migrate the Rules options, perform the following steps:

1 In Microsoft Outlook, click Tools>Rules.
2 Select the settings that you want to migrate.

3 Start the migration.

All the selected settings are migrated from source Microsoft Outlook to destination Microsoft
Outlook 2007.

NOTE: You can migrate both Offline and Online rules.

Migrating Junk E-mail options
To migrate the Junk E-mail options, perform the following steps:

1 In Microsoft Outlook, click Tools >Options>Preferences.
2 Select the settings that you want to migrate.

3 Start the migration.

All the selected settings are migrated from source Microsoft Outlook to destination Microsoft
Outlook 2007.

NOTE: You can migrate both Offline and Online rules.

Migrating E-mail Security and Privacy options
To migrate the Privacy options, perform the following steps:

1 In Microsoft Outlook, click Tools> Trust Centre>Privacy Options.
2 Select the settings that you want to migrate.

3 Start the migration.

All the selected settings are migrated from source Microsoft Outlook to destination Microsoft
Outlook 2007.

To migrate the available E-mail Security options, perform the following steps:

1 In Microsoft Outlook, click Tools>Trust Centre>E-mail Security.
2 Select the settings that you want to migrate.

3 Start the migration.

All the selected settings are migrated from source Microsoft Outlook to destination Microsoft
Outlook 2007.
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C.7

C.8

Migrating Signatures

To migrate the options to create and edit signatures for outgoing messages, replies and forwards,

perform the following steps:

1 In Microsoft Outlook, click Tools >Options> Mail Format>Signatures.
2 Select the settings that you want to migrate.

3 Start the migration.

All the selected settings are migrated from source Microsoft Outlook to destination Microsoft
Outlook 2007.

Migrating Spelling and Auto Correction options

To migrate the Spelling and Auto Correction options, perform the following steps:

1 In Microsoft Outlook, click Tools >Options>Spelling.
2 Select the settings that you want to migrate.

3 Start the migration.

All the selected settings are migrated from source Microsoft Outlook to destination Microsoft
Outlook 2007.

Migration Settings
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D.1

Supported Settings in Personality

Migration

The following sections list the settings that you can migrate by using Personality Migration:

¢ Section D.1, “System Settings,” on page 53

¢ Section D.2, “Application Settings,” on page 54

System Settings

You can migrate the following system settings with ZENworks Personality Migration:

Table D-1 System Settings

Categories Settings
Accessibility + Accessibility
Appearance * Appearance

Date and Regional Settings

Keyboard, Mouse and Other Hardware

Desktop Icons
Fonts

Folder Options
Login Screen
Screen Saver
Task Bar
Wallpaper

Date and Time

Regional Settings

Keyboard
Mouse

Power Options
Local Printers

NOTE: ZENworks 11SP2 does not support
migrating of a network printer although you can
select it.

Supported Settings in Personality Migration
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Categories Settings

Network + Dialup

+ Mapped Drives
+ Networking

+ Sharepoints

Sounds and Multimedia + Sounds

NOTE: While migrating system settings such as themes that are unavailable in the operating system
on the destination device, then after migration, the default theme of the operating system on the
destination device is applied.Some system settings may not be migrated correctly on 64 bit machines.

D.2 Application Settings

Review the following sections to understand the application settings and versions that you can
migrate by using ZENworks Personality Migration:

*

*

*

Section D.2.1, “Adobe Applications,” on page 54

Section D.2.2, “Corel Applications,” on page 55

Section D.2.3, “IBM Applications,” on page 55

Section D.2.4, “Microsoft Applications,” on page 55

Section D.2.5, “Palm Applications,” on page 58

Section D.2.6, “Qualcomm Applications,” on page 58

Section D.2.7, “Research in Motion Applications,” on page 58
Section D.2.8, “Sun Applications,” on page 58

Section D.2.9, “America Online Applications,” on page 58
Section D.2.10, “GAIM Applications,” on page 59

Section D.2.11, “Mozilla Foundation Applications,” on page 60
Section D.2.12, “OpenOffice.org Applications,” on page 61

D.2.1 Adobe Applications

You can migrate settings for the following applications with ZENworks Personality Migration:

*

*

*

Acrobat7.0/8.0

Reader 6.0/7.0/8.0

Mlustrator 9.0 /10.0 /11.0/12.0
ImageReady 7.0.1/8.0/9.0
InDesign2.0/3.0/4.0
PageMaker 7.0

Photoshop 7.0/8.0/9.0
Dreamweaver 8.0 / MX / MX 2004
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+ Fireworks 8.0 / MX
+ Flash 8.0 / MX
¢ Freehand 10.0 / MX

D.2.2 Corel Applications

You can migrate settings for the following applications with ZENworks Personality Migration:

¢ Paint Shop Pro 10.0

D.2.3 IBM Applications

You can migrate settings for the following applications with ZENworks Personality Migration:

+ Lotus Notes 6.5

D.2.4  Microsoft Applications

You can migrate settings for the following applications with ZENworks Personality Migration:

* Access 2000 /2002 / 2003 / 2007

+ Excel 2000 /2002 / 2003 / 2007/2010

¢ FrontPage 2000 /2002 / 2003 / 2007

+ PowerPoint 2000 / 2002 / 2003 / 2007/2010
+ Word 2000 /2002 / 2003 / 2007/2010

You can migrate the following settings for Word:

*

*

*

*

*

Custom Dictionaries

Spelling and Grammar Checking Options
Autocorrect Entries and Options

Change Tracking Options

Document Display Options

Print Options

Default Template

Toolbars

Assistant Options

¢ Internet Explorer 5.0/5.5/6.0/7.0/8.0/9.0

You can migrate the following settings for Internet Explorer:

*

*

*

*

*

Homepage
Favorites

Cookies (store only)
Cookie Permissions

Custom Fonts and Colors
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¢ Pop-up Permissions

¢ Proxy Settings
¢ Language Settings
¢ Security Settings

¢ Advanced Settings

¢ MSN Messenger 7.0 /7.5 / 8.0
¢ Office Shortcut Bar 2000 / 2002
¢ Outlook 2000 /2002 / XP /2003 / 2007/ 2010

You can migrate the following settings for Outlook:

Settings Options

Email .

Calendar .

Contact .

Task .

Account Details: Mail server name and login nhames

Account Passwords (Store only)

E-Mail messages and Directory structure

E-Mail marked as Read or Unread

Security Options: Connect via SSL, secure authentication
Signatures

Composition preferences (HTML, rich text, or plain text)
Account settings such as Leave on Server and Server timeout
Incoming mail rules (Outlook to Outlook only)

Frequency of sending/receiving messages (Outlook to Outlook only)
Outlook data files

Offline folders file

Junk e-mail options

Custom Dictionary

Spelling and Auto Correction

Calendar Entries
Reminder Time and Options
Appointment Recurrence Options

Work Day and Week Settings

Contact Entries

Distribution List Entries
Default Contact Display Name
Default Contact Sort Order

Contact Nick Names

Task Entries
Reminder Time Options

Task Recurrence Options
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NOTE:

+To migrate the Microsoft Outlook archive.pst file from a customized location, store and
apply the Microsoft Outlook settings from an administrator’s account.

+The following two scenarios are not supported for Microsoft Outlook:

+You cannot migrate the settings of a 32-bit version of Microsoft Outlook, installed on a
Windows 7 64-bit machine, to a 64-bit version of Microsoft Outlook on a Windows 7
64-bit machine.

+You cannot migrate the settings of a 32-bit version of Microsoft Outlook, installed on a
Windows 7 64 machine to a 32-bit version of Microsoft Outlook installed on a
Windows 7 or Windows XP machine.

+The PNP file created to store the 32-bit version Microsoft Outlook settings on Windows 7 is not
backward compatible with lower versions of Personality Migration.

Outlook Express 5.0 / 6.0

You can migrate the following settings for Outlook Express:

Settings Options

Email + Account Details: Mail server name and login names
¢ Account Password (Store only)
+ E-Mail messages
¢ E-Mail marked as Read or Unread
+ Security Options: Connect via SSL, secure authentication
¢ Signatures
+ Composition preferences (HTML, rich text, or plain text)
¢ Account settings such as Leave on Server and Server timeout

+ Email Directory Structure

Contact + Contact Entries

+ Distribution List Entries

Project 2000 / 2003 / 2007
Publisher 2002 / 2003 / 2007
NetMeeting 3.0

Visio 2000 / 2002 / 2003 / 2007
Windows Media Player 9.0 / 10.0
Windows Media Player Audio 8.0
Windows Media Player Video
Mail

Infopath
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D.2.5

D.2.6

D.2.7

D.2.8

D.2.9

Palm Applications

You can migrate settings for the following applications with ZENworks Personality Migration:

¢ Palm Desktop 4.0/ 4.1

Qualcomm Applications

You can migrate settings for the following applications with ZENworks Personality Migration:

¢ Eudora 6.2

Research in Motion Applications

You can migrate the following applications with ZENworks Personality Migration:

¢ BlackBerry Desktop 4.0/ 4.1

Sun Applications

You can migrate the following applications with ZENworks Personality Migration:

+ StarOffice Writer 8.0

America Online Applications

You can migrate the following applications with ZENworks Personality Migration:

¢ AOL Instant Messenger 6.0
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You can migrate the following settings for AOL Instant Messenger:

Application Settings

AOL Instant Messenger 1. Account Information
¢ Screen Names
¢ Password Preferences
+ Autologin Preferences
¢ Connection and Proxy Settings
2. Account Settings
+ Buddy List Preferences
+ Privacy Options
¢ Sign in Options
+ Notification Options
+ Notification Sound Files
+ IM/Chat Preferences
¢ Font and Window Color Options
+ Away/ldle Messages and Options

* Stock Ticker Information

D.2.10 GAIM Applications

You can migrate the following applications with ZENworks Personality Migration:
¢ GAIM1.2/13/14/15/2.0

You can migrate the following settings for GAIM:

Application Settings

GAIM 1. Account Information
¢ Screen Names
¢ Password Preferences
* Autologin Preferences
+ Connection and Proxy Settings
+ Protocol and Server Settings
2. Account Settings
+ Buddy List Preferences
+ Notification Options
+ Notification Sound Files
¢ IM/Chat Preferences
+ Away/ldle Messages and Options

* Message Format Options
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D.2.11 Mozilla Foundation Applications

You can migrate the following applications with ZENworks Personality Migration:

¢ Firefox0.9/0.10/1.0/1.5/2.0/3.0.x/3.5.x

You can migrate the following settings for Firefox:

*

*

*

*

*

Homepage

Bookmarks

Cookies

Cookie Permissions

Custom Fonts and Colors
Pop-up Permissions

Proxy and Connection Settings
Language Settings

Download Manager Options

Advanced Settings

¢ Mozillal1l.7/1.8

You can migrate the following settings for Mozilla:

*

*

*

*

*

Homepage

Bookmarks

Cookies

Cookie Permissions

Custom Fonts and Colors
Pop-up Permissions

Proxy Settings

Language Settings
Download Manager Options

Advanced Settings

¢ Mail1.6/1.7/1.8

You can migrate the following settings for Mail:
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Settings Options

Email + Account Details: Mail server name and login
names

+ Account Passwords
+ E-Mail messages and Directory Structures
+ E-Mail marked as Read or Unread

+ Security Options: Connect via SSL, secure
authentication

+ Signatures
¢ Composition preferences (HTML or Plain text)

+ Account settings such as Leave on Server and
Server timeout

¢ Incoming Mail Rules (from Mozilla/Thunderbird
only)

Contact + Contact Entries

¢+ Thunderbird 0.8/1.0/1.5

You can migrate the following settings for Thunderbird:

Settings Options
Email + Account Details: Mail server name and login
names

* Account Passwords
+ E-Mail messages and Directory Structures
+ E-Mail marked as Read or Unread

+ Security Options: Connect via SSL, secure
authentication

* Signatures
+ Composition preferences (HTML or Plain text)

+ Account settings such as Leave on Server,
and Server timeout

D.2.12 OpenOffice.org Applications

You can migrate the following applications with ZENworks Personality Migration:
¢ OpenOffice.org Writer 1.1 /2.0

You can migrate the following settings for OpenOffice.org Writer:
¢ Custom Dictionaries
¢ Spell Check Options

¢ Autocorrect Entries and Options
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*

Change Tracking Options
¢ Document Display Options

*

Default Template

*

Toolbars

*

Filepaths
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Understanding Variables

Variables are strings that contain paths to system directories such as Program Files and My Pictures.
These variables are enclosed by the percent (%) symbol. The values for these variables are
automatically set when Personality Migration starts.

For example, the %0s5% variable expands the directory where the operating system is installed on the
device. For more information on how to migrate the variables, see Section 5.1.2, “Using the Template
Builder to Create a Template,” on page 28

The following table describes the variables that are used in Personality Migration. The table lists the
values for Windows XP and Windows 7, but the variables can be used on all supported operating
systems. The examples assume that the operating systems are installed on the C:\ drive.

Variable Description Value for Windows XP Value for Windows 7
applicationdata The Application Data C:\Documents and C:\Users\username\
directory that contains Settings\username\A AppData\Roaming

application-specific datafor pplication Data
the current user

commonapplicationdata ~ The Application Data C:\Documents and C:\ProgramData
directory that is common to Settings\All
all users Users\Application
Data
commondesktop The Desktop directory that C:\Documents and C:\Users\Public\De
is common to all users Settings\All sktop
Users\Desktop
commondocuments The Documents directory ~ C:\Documents and C:\Users\Public\Do
that contains documents Settings\All cuments
that are common to all Users\Documents
users
commonprogramfiles The Common Files C:\Program C:\Program

directory that contain files  Files\Common Files Files\Common Files
common to various

applications

commonstartmenu The Start Menu directory ~ C:\Documents and C:\ProgramData\Mic
that contains the Start Settings\All rosoft\Windows\Sta
menu items common to all  Users\Start Menu rt Menu
users

computername Name of the device If the hostname is abc, the If the hostname is abc,

value of the variable is abc the value of the variable
is abc
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Variable

Description

Value for Windows XP

Value for Windows 7

cookies

desktop

favorites

fonts

history

internetcache

localapplicationdata

mymusic

mypictures

myvideo

0s

personal

profile

The Cookies directory that
contains the browser
cookies

The logical desktop for the
current user

The Favorites directory that
contains the favorite items
for the current user

The Fonts directory that
contains system fonts

The History directory that
contains the browser
history for the current user

The Temporary Internet
Files directory that contain
the temporary Internet files
for the current user

The directory that contains
the local application-
specific data that is used by
the current user

The My Music directory for
the current user

The My Pictures directory
for the current user

The My Video directory for
the current user

The Windows install
directory

The directory that contains
the user's documents

The directory that contains
the current user's profile

C:\Documents and
Settings\username\C
ookies

C:\Documents and
Settings\ username
\Desktop\

C:\Documents and
Settings\ username
\Favorites

C:\WINDOWS\Fonts

C:\Documents and
Settings\
username\Local
Settings\History

C:\Documents and
Settings\username\L
ocal
Settings\Temporary
Internet Files

C:\Documents and
Settings\ username
\Local
Settings\Applicatio
n Data

C:\Documents and
Settings\
username\My
Documents\My Music

C:\Documents and
Settings\
username\My
Documents\My
Pictures

C:\Documents and
Settings\username\M
y Documents\My
Videos

C:\WINDOWS

C:\Documents and
Settings\username\M
y Documents

C:\Documents and
Settings\username

C:\Users\ username
\AppData\Roaming\M
icrosoft\Windows\C
ookies

C:\Users\username\
Desktop\

C:\Users\
username\Favorites

C:\WINDOWS\Fonts

C:\Users\ username
\AppData\Local\Mic
rosoft\Windows\His
tory

C:\Users\username\
AppData\Local\Micr
osoft\Windows\Temp
orary Internet
Files

C:\Users\ username
\AppData\Local

C:\Users\
username\Music

C:\Users\
username\Pictures

C:\Users\username\
Videos

C:\Windows

C:\Users\username\
Documents

C:\Users\username
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Variable

Description

Value for Windows XP

Value for Windows 7

profiles

programs

quicklaunch

recent

sendto

startmenu

startup

system

tempdirectory

templates

username

The directory that contains
the All Users profile

The Programs directory

The Quick Launch directory

The directory that contains

shortcuts to the documents

recently used by the user

The SendTo directory that

contains the Send To menu

items

The Start Menu directory
that contains the Start
menu items

The Startup directory that
contains the startup items
for the user

The System directory

The Temp directory that

contains the temporary files

The Template directory that
stores document templates

The name of the currently
logged-in user

C:\Documents and
Settings

C:\Documents and
Settings\username\S
tart Menu\Programs

C:\Documents and
Settings\username\A
pplication
Data\Microsoft\Inte
rnet Explorer\Quick

C:\Documents and
Settings\username\R
ecent

C:\Documents and
Settings\username\S
endTo

C:\Documents and
Settings\username\S
tart Menu

C:\Documents and
Settings\username\S
tart
Menu\Programs\Start

up

C:\WINDOWS\system32

C:\DOCUME~1\usernam
e\LOCALS~1\Temp\

C:\Documents and
Settings\username\T
emplates

If the username is abc, the
value of the variable is
abc.

C:\Users

C:\Users\username\
AppData\Roaming\Mi
crosoft\Windows\St
art Menu\Programs

C:\Users\username\
AppData\Roaming\Mi
crosoft\Internet
Explorer\Quick
Launch

C:\Users\username\
AppData\Roaming\Mi
crosoft\Windows\Re
cent

C:\Users\username\
AppData\Roaming\Mi
crosoft\Windows\Se
ndTo

C:\Users\username\
AppData\Roaming\Mi
crosoft\Windows\St
art Menu

C:\Users\username\
AppData\Roaming\Mi
crosoft\Windows\St
art
Menu\Programs\Star
tup

C:\WINDOWS\system3
2

C:\Users\username\
AppData\Local\Temp
\

C:\Users\username\
AppData\Roaming\Mi
crosoft\Windows\Te
mplates

If the username is abc,
the value of the variable
is abc.
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F1

Cross-User Migration Scenarios

The flowcharts in this section describe the various scenarios you might encounter while migrating

user personalities.

¢ Section F.1, “Migration Scenarios If the PNP file has the personalities of all users,” on page 67

¢ Section F.2, “Migration Scenarios If the PNP file has the personality of the currently logged-in

user,” on page 68

¢ Section F.3, “Migration Scenarios If the PNP File has the Personality of a Specific User,” on

page 70

¢ Section F.4, “Migration Scenarios If the PNP File has the Personalities of Multiple Specific

Users,” on page 71

Migration Scenarios If the PNP file has the personalities of

all users

¢ Scenario 1: Selecting the template option Migrate the settings for the currently logged in user

¢ Scenario 2: Selecting the template option All users to migrate

¢ Scenario 3: Selecting the template option Add users to migrate, and specify a user

Scenario 1: Selecting the template option Migrate the settings for the currently

logged in user

Is any
user in the PNP the
currently logged-in
user?

Migrate the user’s
personality to the

destination device.

Is the user
in the PNP also
on the destination
device?

The migration failed.
See the error log.

Cross-User Migration Scenarios
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Scenario 2: Selecting the template option All users to migrate

|

Are all
users in the PNP also
on the destination
device?

Migrate the
personalities of
the users.

Scenario 3: Selecting the template option Add users to migrate, and specify a

user

Is the user
specified in the
template also in
the PNP?

Is the
user specified in
the template also on
the destination
device?

Migrate the user’s
personality.

Create those users
who are not on the
destination device.

The migration failed.
See the error log.

Create the user on the
destination device.

F.2 Migration Scenarios If the PNP file has the personality of

A

the currently logged-in user

¢ Scenario 4: Selecting the template option Migrate the settings for the currently logged in user
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¢ Scenario 5: Selecting the template option All users to migrate

¢ Scenario 6: Selecting the template option Add users to migrate, and you specify a user

Scenario 4: Selecting the template option Migrate the settings for the currently

logged in user

Migrate the user’s personality without mapping the users by their names.

Scenario 5: Selecting the template option All users to migrate

Is the user
in the PNP also
on the destination
device?

Migrate the user’s

Create the user on the
destination device.

A

personality.

Scenario 6: Selecting the template option Add users to migrate, and you specify

a user

Is the user
specified in the
template also in
the PNP?

Is the
user specified in
the template also on
the destination
device?

Migrate the user’s

The migration failed.
See the error log.

Create the user on the
destination device.

personality.
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F.3 Migration Scenarios If the PNP File has the Personality of a
Specific User
¢ Scenario 7: Selecting the template option Migrate the settings for the currently logged in user

¢ Scenario 8: Selecting the template option All users to migrate

¢ Scenario 9: Selecting the template option Add users to migrate, and you specify a user

Scenario 7: Selecting the template option Migrate the settings for the currently
logged in user

Is the
currently logged-in
user on the destination
device also in
the PNP?

Is the
user in the PNP
file the currently
logged-in
user?

The migration failed.
See the error log.

Migrate the user’s
personality.

Scenario 8: Selecting the template option All users to migrate

Is the
user specified in
the PNP also on
the destination

device?

On the destination
device, create the user
who is in the PNP file.

Migrate the user’s _ J
personality.
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F4

Scenario 9: Selecting the template option Add users to migrate, and you specify
a user

Is the user
in the template also
in the PNP?

The migration failed.
See the error log.

Is the user
in the template also
on the destination
device?

Create the user on the
destination device.

Migrate the user’s _ J
personality.

Migration Scenarios If the PNP File has the Personalities of
Multiple Specific Users
¢ Scenario 10: Selecting the template option Migrate the settings for the currently logged in user

¢ Scenario 11: Selecting the template option All users to migrate

¢ Scenario 12: Selecting the template option Add users to migrate, and you specify multiple users

Scenario 10: Selecting the template option Migrate the settings for the currently
logged in user

Is the user
on the destination
device also in
the PNP?

Is any
user in the PNP the
currently logged-in
user?

The migration failed.
See the error log.

Migrate the user’s
personality.
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Scenario 11: Selecting the template option All users to migrate

|

Are all
users in the PNP also
on the destination
device?

Migrate the user’s
personality.

Scenario 12: Selecting the template option Add users to migrate, and you specify

multiple users

Are any
users in the
template also in
the PNP?

Are these
users also on
the destination
device?

Migrate the user’s
personality.

Create those users
who are not on the
destination device.

The migration failed.
See the error log.

Create the user or
users on the
destination device.

A
\

72

ZENworks 11 SP2 Personality Migration Reference



Gl

Documentation Updates

This section contains information on documentation content changes that were made in this
Personality Migration Reference for Novell ZENworks 11 Configuration Management. The information
can help you to keep current on updates to the documentation.

The documentation for this product is provided on the Web in two formats: HTML and PDF. The
HTML and PDF documentation are both kept up-to-date with the changes listed in this section.

If you need to know whether a copy of the PDF documentation that you are using is the most recent,
the PDF document includes a publication date on the title page.

The documentation was updated on the following date:

¢ Section G.1, “March 20, 2012: 11 SP2,” on page 73

March 20, 2012: 11 SP2

Change

Location

Section D.2.4, “Microsoft Applications,” on page 55

Appendix B, “Troubleshooting Personality Migration,”

on page 43

Updated the section to include support for:

* |Internet Explorer 9.0

+ Microsoft Office 2010
Added the following scenarios:

+ “Where do | find the Personality Migration log
files for Microsoft Outlook?” on page 44

+ “Unable to open Microsoft Outlook after storing
the Outlook settings” on page 45

Documentation Updates
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